Se lanza una actualización de seguridad para Sudo

La gente del proyecto Debian Linux ha lanzado una actualización de seguridad para Sudo la cuál corrige una vulnerabilidad crítica. Dicho fallo de seguridad afectaba tanto a Debian 9 como a Ubuntu 19.10, 18.04 LTS y 16.04 LTS.

actualización sudo

Hace pocas semanas se descubrió una vulnerabilidad en el paquete sudo que afectaba las versiones anteriores a la 1.8.26. Dicho fallo de seguridad permitía a un usuario sin privilegios, obtener todos los permisos root, siempre y cuando pwfeedback estuviese habilitado.

«Joe Vennix descubrió una vulnerabilidad de desbordamiento de buffer basada en pilas en sudo, un programa diseñado para permitir de manera limitada, privilegios de super usuario a usuarios específicos. Cuando la opción «pwfeedback» se encontrase habilitada, un usuario sin privilegios podría aprovechar este defecto y hacerse con privilegios root completamente.» Indicó Salvatore Bonaccorso a través de la lista de seguridad de Debian.

Vale reseñar que la opción pwfeedback viene habilitada por defecto en las distros Linux Mint y Elementary OS. Esto no es así en distros como Debian 9 y Ubuntu las cuales no estarían viéndose afectadas por dicha vulnerabilidad en sudo.

Es de recordar que la opción pwfeedback provee una visualización al usuario cuando este introduce su contraseña al usar sudo. Por lo general, la distros con dicha opción habilitada mostraba al usuario una serie de asteriscos.

Las nuevas versiones de actualización para sudo son:

Debian 9: 1.8.19p1-2.1+deb9u2

Ubuntu 19.01: 1.8.27-1ubuntu4.1

Ubuntu 18.04 LTS: 1.8.21p2-3ubuntu1.2

Ubuntu 16.04 LTS: 1.8.16-0ubuntu1.9

Las nuevas versiones de seguridad ya están disponibles a través de los gestores de actualización de Debian y Ubuntu.

Vía: 9to5Linux

Acerca de Ramon Marquez

Redactor de contenidos webs y amante de las tecnologías!

Deja un comentario

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.