Ubuntu corrige la vulnerabilidad MDS encontrada en varios CPU Intel

La gente de Ubuntu ha anunciado el lanzamiento de una actualización de seguridad que corrige la vulnerabilidad MDS (Microarchitectural Data Sampling). Dicho error afectaba a varios procesadores Intel.

vulnerabilidad MDS

Al igual que como hizo Microsoft el día de hoy con los parches correspondientes al mes en curso, Canonical ha liberado un arreglo para la vulnerabilidad MDS. Este error y tal como se indicó al inicio, afectaba a varios CPU’s Intel y el mismo permitía que un proceso malicioso leyera información de otro proceso ejecutándose en el mismo núcleo del procesador.

De acuerdo con la nota oficial, El error ocurría debido al uso de varios elementos (buffers) dentro del núcleo del CPU. Si un proceso es capaz de escoger datos de manera especulativa en esos buffers, entonces se puede inferir que esos datos pertenecen a otro proceso en ejecución. Vale reseñar que los buffers no se borran al cambiar entre procesos.

Es importante destacar que este proceso de especulación de datos incluía la conmutación de procesos en espacios de usuarios diferentes, la conmutación entre el kernel y el espacio de usuario, y la conmutación entre un sistema huésped y su invitado cuando se usaba la virtualización.

Los parches de seguridad que mitigan la vulnerabilidad MDS en Ubuntu (y distros basadas en ella), se encuentran en las recientes actualizaciones de
intel-microcode, qemu, y kernel Linux. Estos arreglos ya se encuentran disponibles en los gestores de actualizaciones de Ubuntu 19.04, 18.10, 18.04, y 16.04; así como también para Ubuntu 14.04 ESM.

Sobre nosotros Ramon Marquez

Un Linuxero que comparte su pc world con Windows en un universo maravilloso!!!

Deja un comentario

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.