gestionando los paquetes Snaps en Ubuntu 16.04

Como ya sabemos, Ubuntu 16.04 significa el trampolín para lanzar los paquetes snaps en el escritorio y con el siguiente tutorial les mostraré los comandos mas básicos que debes tener en cuenta mientras, o bien se desarrolla una nueva herramienta gráfica para administrarlo o se añaden hacks al Ubuntu Software para hacerlo compatible con los snaps.

ubuntu-snap

estos son los comandos más básicos que debes saber para gestionar los paquetes Snaps en Ubuntu 16.04:

Para ver los paquetes snaps disponibles, simplemente debemos introducir el siguiente comando vía terminal:

snap find

buscar-snaps

Si por el contrario, queremos buscar un paquete Snap en particular, entonces lo haremos con el comando:

snap find (nombre del paquete)

encontrar-paquetes-snaps

Para instalar algún paquete snap, debemos usar el siguiente comando:

sudo snap install (nombre del paquete)

Es importante señalar que si es primera vez que vamos a realizar una instalación de un paquete snap, automáticamente se descargará el ubuntu-core el cuál pesa alrededor de 80mb.

instalando snaps

Para buscar y actualizar algún paquete Snap, debemos usar el comando:

sudo snap refresh

actualizar-paquetes-snaps

Si queremos ver todos los paquetes Snaps instalados, simplemente introducimos el comando:

snap list

listas-paquetes-snap

Para remover un paquete snap, usaremos el comando:

sudo snap remove (nombre del paquete)

Si deseamos ver la lista de cambios de paquetes snaps instalados o desinstalados en el sistema, debemos usar el comando:

snap changes

cambios-paquetes-snap

Vale reseñar que para abrir dichos paquetes, podemos hacerlo como normalmente se suele hacer ya que a la final, se trata de la misma aplicación…!

Vía: RedesZone e IslaBit

Sobre nosotros Ramon Marquez

Un Bloguero del mundo

2 comentarios

  1. Está bien esto de los snaps, al menos en su concepción me parece muy interesante el hecho de poder superar el eterno problema de las incompatibilidades entre dependencias… que el programa X quere una versión concreta de una dependencia, que el ppa Y quiere una versión superior… y ya la hemos liado. La idea es muy interesante en su concepción.

    Pero la implementación aún deja mucho que desear, por lo que se ve. Yo he probado Krita en el paquete snap (que es lo que te ofrece Ubuntu Software, para instalar el DEB de toda la vida hay que tirar de terminal o de Synaptic), y me ha decepcionado, aunque solo sea porque no es capaz de resolver el idioma de la interfaz, se queda en inglés y de ahí no se mueve, de hecho, ha herramienta de configuración de idioma de Krita solo te muestra el inglés.

    No sé si es cosa de Krita o si es cosa de ubuntu, pero todo indica que aún estamos viendo un experimento, lo cual no tiene por que ser malo, pero si, efectivamente, estamos probando aún los snap esto debería ser transparente para el usuario en Ubunru Software.., pero no es así, no se informa al usuario que va a instalar una versión experimental de la nueva paquetería y lo que el usuario se encuentra (al menos con Krita) es un programa que parece ser funcional pero que está incompleto.

    Creo que en esto Canonical no lo está haciendo del todo bien, Los que llevamos un tiempo en Ubuntu sabemos de que va la cosa, pero los nuevos usuarios que instalen la versión 16.04 puede ser que estén algo desconcertados con estos cambios.

    Saludos.

    • Me respondo a mi mismo después de leer las notas del snap de Krital. Aunque en inglés, están ahí.

      Por lo que se ve, no es que no funcionen bien las traducciones, es que no existen según esta nota:

      Notes: no translations are available yet, and due to a bug in Ubuntu, this snap doesn’t work with proprietary video drivers, e.g. for NVidia.

      Si lo he entendido bien, también hay problemas con drivers nVidia.

Deja un comentario